Folgen

Update 8.0.0 | Fehler mit "bestit_amazon_alexa.subscriber.config_controller_subscriber"

Bei einem Update auf Amazon Pay (Alexa ready) Version 8.0.0 kann es vorkommen, dass veraltete Dateien im Cache einen Server error 500 hervorrufen.

Kontext

PHP Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "bestit_amazon_alexa.subscriber.config_controller_subscriber". in /var/www/genxtreme/htdocs/shop/vendor/symfony/dependency-injection/Container.php:288

 Lösungsansatz

Löschen Sie den Shopware Cache. Sofern dieser sich nicht mehr mit "regulären Boardmitteln" wie $ ./bin/console sw:cache:clear löschen lässt, dann auf dem direkten Weg.

Entfernen Sie im Ordner /var/cache/production_********/proxies/
die Dateien:

  • BestitAmazonPayContainer.php
  • BestitAmazonPayContainer.php.meta

Danach steht das Backend wieder zur Verfügung und der Update Vorgang kann noch mal wiederholt werden.

War dieser Beitrag hilfreich?
0 von 0 fanden dies hilfreich
Haben Sie Fragen? Anfrage einreichen

Kommentare